Total Commander Ultima Prime

One For All

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
win 7 taskbar
as of version 5.1 and new thingy that measures various system parameters, the taskbar on win7 is not working correctly. i have pinned tcup to taskbar, but when i click on it a new instance shows up at the end of taskbar (like it isn't pinned) and every new instance i open stacks at that new temporary icon. i tried pinning that temp icon but it pins total commander exe instead, and clicking on it starts tcup without new features (which are nice and useful) and also uses tc icon.
i hope this will be fixed in next release

example: [Image:]
os: windows 7 ultimate x64
i'm no programmer (i can compile a program that prints "hello world!") but i figured that the problem was in tcup exe launching tc exe and other stuff so win7 doesn't recognize it's the same program.
maybe there's a way to trick windows into believing it's the same process, or some script in visual basic that allows programmers to override some functions (a shot in the dark). dunno, but i really like the new taskbar, it's similar to one on mac os and much more functional than the mess in winxp taskbar when one has many programs open at once.
back to topic, as a temporary solution maybe you could add an option to turn off the titlebar info as i believe it's the cause of the problem. i used previous versions up to 5.0 and taskbar worked fine.
also i would like other w7 users to test this function and report as maybe my problem is an isolated issue or has something to do with 64bit os.
on the other hand, tcup is not the only program that behaves this way - of the ones i tried to pin nero 10 isn't working right, and also rapidshare manager.
(08-27-2010, 04:59 PM)Pawel Wrote: You can turn it off if you want. Just open tc up.ini file and set option: ShowInfo=0.
If you do this, TC UP.exe will start TC and close immediately.

tried this now and it didn't help. maybe there's a way to completely disable this script or whatever it is from running (i noticed when i first started the new version that my firewall prompted about "tc up turbo" trying to connect to internet.
and i tried disabling all of the update options in .ini file - didn't work either.

(08-27-2010, 04:59 PM)Pawel Wrote: But, could you explain your issue more detailed? Step by step. Maybe I am missing something...

i don't know your background knowledge about w7 taskbar so i'll try to get into detail.
w7 taskbar its something like tabs combined with quick launch on winxp but with added funcionality. all instances of a same program can be stacked into one icon, eg. several notepad documents will all be on one icon and rollover with mouse will reveal open instances as clickable thumbnails. it's especially useful with everyday programs as they can be pinned down to taskbar and they will always remain in the same place. thera is much more but this is basically my problem. i'm used to have opera always in the same place on taskbar, so when i want to use it i can instantly open it without searching for the icon. when it's open, icon will be lit and remain in the same position, so when i'm switching between eg. total commander, opera and photoshop i don't have to search for it's tab on taskbar and if i have more then one instance of a program they will not be scattered all over but remain in it's 'slot'.

my problem with nero burning rom 10, rapidshare manager and as of version 5.1 tcup too, is this:
a program is closed
i click on it's icon to open it
instead of lighting-up it's icon i it's rightful space - a new icon is created in the new space on the end of taskbar icons
in short, a program is behaving like it's not one of the pinned programs

about 60-70% of the time i spend on my computer i'm actively using tcup, most of the time with a few other apps (photoshop, opera, aimp etc.) so it really helps me having them in their rightful spots so i can find them in a nanosecond. i can also use shortcut win+# (tc is first after start menu button so it's win+1) and open them without using mouse. in normal conditions it will open the program, or, if a program is already running, this shortcut will switch to it's last used instance. but now when i use the shortcut it will open up a new instance of it.

well, i think that's more then enough explaining. anyway, i really love tcup and if there's no solution i'll just use previous version that worked (5.0). thank you for your time, i know it's a minor flaw compared with the power of tcup, but i guess as more and more users discover that win7 is the best windows ever, the more of them will have this issue (i would even dare to call w7 better than macosx, but definetely eons ahead of the good ole mule xp, and vista... well... anything is better than vista so there's no need to compare).
(08-27-2010, 07:28 PM)Pawel Wrote: Btw, I am an author of TC UP.exe and TC UP Turbo.exe programs Tongue Yes, you can blame me Big Grin

well, then i'll blame you for creating the most useful tool on my computer. tc is nothing without up.

(08-27-2010, 07:28 PM)Pawel Wrote: Yes, this is what I wanted to see. This is problem I am thinking how to resolve. The problem is, that we pin TC UP icon. But TC is the real program we see at the end. So, Windows create new icon. For now, I am not sure how to fix it, I am not even sure if this is possible, as we are talking about 2 programs, not 1 (TC UP.exe (pinned) launch TC).

well this taskbar function is fairly new and i see that other programmers overlooked this kind of usage. maybe there's a simple solution already posted somewhere, maybe even on microsoft's support articles.

(08-27-2010, 07:28 PM)Pawel Wrote: We will try to fix that. There will be soon TCUP 5.2. I fixed some bugs there, maybe some of yours.

thanks, i'll wait for it.
short one asks

Have you configured tc so it opens only once?

I hope mine in English feels well enough to understand around the question

kurze frage

Hast du tc so konfiguriert das es sich nur einmal öffnet ?

Ich hoffe mein englisch ist gut genug um die Frage zu verstehen

I don't know of others but I'm stil having this problem with W7 x64 and TC Up 5.2. Is there a solution on the way?

I am having this problem with W7 x64 and TC Up 5.2. Is there a solution on the way? I am not a programmer yet tried to sort things out. sometimes stuck also like here!!
Please help
I did it! I was working in safe mode and it crossed my mind to try to pin down tcup to taskbar. It worked in safe mode so I left it there. Somehow this solved the problem and now the icon works like it should.

Please everyone with this problem test this solution to see if this works.

Forum Jump:

Users browsing this thread: 1 Guest(s)